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FoodEx2 browser draft user guide

If you are a user approaching the FoodEx2 browser for the first time, the following chapters will show
how to install and run the browser. For more experienced users, this guide provides a quick reference
to functions that are rarely used.

1.1. How to install and execute the tool

Installing the Foodex Browser is a simple procedure, not requiring much effort. In particular, perform
the following operations:

1. Extract the zip file in the folder where you want to install the Foodex Browser.

2. Once that the extraction procedure is terminated, open the DefaultProperties.xml file (located
in the User Files directory) with a generic text editor program.

3. Search in the file the line related to the key “Application.Dir”:

4. Change the content of the entry path (in the example the “D:\FoodexBrowserHome”) with the
path of the directory which will contain the Foodex database in your PC. You can easily do this
by opening the folder which contains the Tool and copying the address as text from the

Windows® Explorer,

and pasting the address in the DefaultProperties file in Notepad®
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5. Save the text file with File->Save.

6. Run the CatalogueBrowser.exe application. A warning should be raised telling you that the
database is empty.

Press OK, then you should be able to see the Foodex Browser main page without any data
loaded.

7. Click in the upper left menu, File -> Open.

8. Select the .catalog file (i.e. the database) which you want to load into the Foodex Browser.
If everything goes fine, you will see the Foodex Browser with data loaded into it.
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1.2. Features of the tool

1.2.1. Main menu

The main menu includes four tabs: File, Edit, Tools and Help.

You can access several functionalities of the Foodex Browser
from the Main menu. You can find it in the upper left corner of
the main page.

The File menu item allows you to open a Foodex catalogue in
the browser (Open…) or to save the current catalogue in a
.catalog file (Save as…). Moreover, you can create a simple
report for visualization purposes just clicking the Report item.
More precisely, you can select the terms that you want to
report and you can choose if some basic statistics should be
included in the report file, or not (for further details on reports
see Section 1.2.1.2).

Finally, you can exit the tool with the Exit item.

The Edit menu item offers to you three important features
which help the Foodex navigation. In particular, you can
collapse the navigation tree (i.e. all the open elements of the
main tree will be closed) or you can expand or collapse a
node, that is, all the terms that are under the term selected in
the tree will be expanded or closed respectively.
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• Favourite Pick List; in case you have pre-defined lists of
codes (pick-lists) here you can select the pick-list that you
want to use in the Foodex Browser. The Pick-lists have a
specific format and must be inserted in the “Picklists”
folder of the Foodex Browser; otherwise they will not be
recognized by the tool. For more information about
picklists see Section 1.2.5.3.

• General Search Options; here you can decide the
search criteria which are used in the Tool for retrieving
terms with search functions (see Section 1.2.2.3 for
further details).

• User Preferences; here you can set your preferences
regarding several aspects of the Foodex Browser. See
Section 1.2.1.1 for further information about user
preferences.

1.2.1.1. Report Window

The Report Window is accessible from the main menu (File -> Report) and allows generating a simple

report for visualization purposes.

You can choose the file name and format by clicking the three
dots on the right. This opens an explorer window, which
allows you selecting these parameters.

Here you can choose the folder which will
contain the report file. Moreover, you can
write the desired report name in the ‘File
name’ field and you can choose the report
format in the ‘Save as type’ field. In
particular, you can choose between .txt
and .htm formats. Once you have inserted
the required information, click the Save
button to return to the main Report
Window.

In the main Report Window, if you want to add statistics on
the numbers of entries at the different levels check the Add
statistics checkbox.
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You can select which hierarchies/facets lists you want to add
in the report by checking them in the tree, which is located in
the centre of the Report Window.

Once you have checked the elements you are interested in,
click the ‘OK’ button in the main Report Window to generate
the report.

The report appears in a separate
window (as preview) and is also
saved in the chosen directory as file.

1.2.1.2. User Preferences

The User preferences help you customize your user experience with the Foodex Browser. In
particular, you can modify the following options:

• Min search chars; this value is the minimum number of characters that has to be inserted in a
search panel in order to execute the search. The default value is set to 3, since searching terms
using only two letters could return too many, not related, results.

• Logging; this value can be either set to TRUE or to FALSE. A TRUE value means that a log file
will be created while the Foodex Browser is working. This is needed only for de-bugging purposes
and should be avoided during normal operations, since a new file is created each time the
browser is opened

• Current directory; this string is the path of the directory which contains the Tool.
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• Copy Implicit Facets; this value can be either set to TRUE or to FALSE. A TRUE value means
that implicit facets codes will be shown in the full codes in the Describe Window. Unless there are
specific needs, the value should be set at FALSE, since while reporting data the implicit facets
shall not be reported.

• Max recent terms; the maximum number of recently described terms recorded by the tool (see
Section 1.2.5.2 for further information).

• Business Rules Checks; this value can be either set to TRUE or to FALSE. A FALSE value means
that the business rules checks (Section 1.2.5.4) will be disabled in the Describe Window. Domains
which are related to consumption should set this value to TRUE, since these rules were created
specifically for consumption data.

1.2.2. Navigation – Search

The Foodex Browser provides you with a powerful and flexible search function to quickly find specific
terms through the catalogue. The principle search function is accessible from the main page of the
Foodex Browser and it allows searching several fields related to the terms.

1.2.2.1. How to execute a search – Search Options

You can execute a search in different ways, but the most
common one consists in searching a term through its name or a
part of it. Remember that you can also search terms through any
names, codes (or a substring of them) related to the terms, such
as scientific names, GEMS and pesticide codes. If you want to
restrict the search to some fields (e.g. code and name) you can
set the options in the General Search Options window (Section
1.2.2.3).

Another core feature which is provided by the Foodex search function is the search methodology.
More precisely, you can choose among three different search strategies:

• Exact Match; the Tool searches the given keywords as a single
string, exactly as they are written; in this case, the order of the
keywords is relevant.

• Any Word; the Tool searches all the terms which contain at
least one of the written keywords. Note that the order of
keywords is not relevant.

• All Word; the Tool searches all the terms which contain all the
written keywords. Note that the order of keywords is not
relevant.

Moreover, you can choose to search terms with two different
scopes using the highlighted radio buttons:

• Search current = search in the current hierarchy only

• Search dictionary = search in all the available hierarchies and
facets lists (the search is performed on the complete
terminology)

1.2.2.2. Executing a search – Example of Usage
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Exact match with “kiwi” and “frui” as search keywords.

The Tool retrieves all the terms which contains in full ‘kiwi’ and
‘frui’. This means that searching “kiwi ruit” (f is missing) will not
find the terms called “kiwi fruits”.

Any word with “kiwi” and “ruit” as search keywords.

The tool retrieves all the terms which contain at least one of the
keywords. This means that the Tool will return all the terms that
contains the word “kiwi” or the word “ruit”. Note that in this case
even if the ‘f’ of ‘fruit’ is missing, nevertheless all the terms are
found, because the two keywords are searched independently.

All word with “kiwi” and “frui” as search keywords.

The Tool retrieves all the terms which contain both the keywords.
Practically, this search method relaxes the constraint imposed by
the Exact Match method.

1.2.2.3. Setting the search preferences

The Foodex Browser provides you with a way to customize the search results. More precisely, you can
choose which type of terms should be included in the results, and which fields of the terms have to be
taken into consideration while searching keywords inside the terms (as previously said in Section
1.2.2.1).

For example, you can choose to display only results for raw primary commodities terms, and to search
keywords only in a subset of additional fields of the term, as scientific names and GEMS code.

You can access the search preferences through the main
menu, clicking “General Search Options” in the “Tools” menu
item.

You can choose which type of terms to visualize in the search
results (Search options table) and which additional fields
should be analysed in the search (Additional search fields
table).

Note that these are general search options; therefore they will
be used in each search panel of the Foodex Browser (except
while searching picklists and recently described terms).
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1.2.3. Navigation – tree browsing

As you may know, the Foodex Browser contains a high number of terms (both list terms and facets),
which are organized in several hierarchies. This chapter will explain how you can navigate this huge
amount of information in an easy manner. The Tool provides you with a way to browse all the terms
with an intuitive interface, which is basically a tree (i.e. a list with indented levels) that shows all the
terms with their parent-child relationships.

The logic is simple:

• A parent term is an element which includes one or more indented terms under it;

• The indented terms are called children of the parent term;

• A term could be both a parent and a child;

• As you open the higher levels of the tree (i.e. you go deeper in the ‘branch’), you will get
more detailed terms until you reach the last level term (‘leaf’).

1.2.3.1. Opening, closing and navigating the tree

The tree panel is shown in the main Foodex Browser page in the frame at the centre of the screen.

The picture shows you the tree panel with the
terms regarding the reporting hierarchy. You can
easily recognize that the main elements are Food,
Feed and Non-food matrices for this hierarchy,
since they are the less indented terms.

You can open and see the children of a parent
term simply by left clicking the white arrow
placed in the left of the term name. Similarly, you
can close the opened children of a parent term by
left clicking again the black arrow.

Remember that you can browse the tree also
using the Expand Node, Collapse Node and
Collapse Tree functions in the Tools menu item.
In the case of Expand node or Collapse node, the
highlighted node is intended; more than one
node may be opened with a single click by
highlighting them all keeping CTRL pressed.

Using the tree panel you can browse both
hierarchies and facets. More precisely, you have
to select the correct radio button highlighted in
red colour, and then you can open the list box
and choose the hierarchy/facet list you want.

You can also filter the tree terms by their
applicability. In fact, you can choose to see either
the terms that are in use in the domain or those
which were in use previously but were dismissed,
or both. A dismissed term is easily recognizable,
since it contains a [DISMISSED] flag at the end of
its name. Non reportable terms are always shown
instead, and they contain a [NON REPORTABLE]
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flag at the end of their name.

Non reportable terms are for example the
hierarchy terms (blue pyramids)

What if you have found the term that you are
interested in, but in the wrong hierarchy/facet
list? You can right click the term to open the
contextual menu and select the “See in other
hierarchies” menu item. This item will show you
all the hierarchies/facet lists where the selected
term is in use and allow changing the
hierarchy/facet list maintaining the selected term
opened.

1.2.3.2. Connection with search

Browsing the tree through the parent-children exploration is easy, but can become a quite long
procedure if you do not know where the term that you are searching is. For this reason, the search
panel of the main page was connected to the tree panel. In fact, if you select a term contained in the
search results box, the tree will show it in the current hierarchy (if present).

If the term is not present in the current
hierarchy, no automatic action is performed.
Nonetheless, you can right click in the search
results box the term that you are interested in to
open a contextual menu, which will allow you to
open the term in any of the hierarchies/facet lists
where it is in use.

1.2.3.3. Contextual menu of the tree

You can access the contextual menu of the tree by
right clicking one element of it. In particular, here you
can do the following:

• See in other hierarchies; open the selected term
in one of the hierarchies which contain it

• Copy; copy the code of the term in the clipboard

• Copy code and name; copy the term code and
its name (tab-separated) in the clipboard

• Copy full code and name; copy the term full
code (i.e. the code also includes the implicit facets
codes) and its name (tab-separated) in the
clipboard

The other menu items provide more complex functions
and therefore are explained in a subsequent specific
Section (Section 1.2.5).
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1.2.4. Navigation – information on the elements

The name of a term could be not sufficient to precisely identify the type of food it represents.
Moreover, you could encounter some terms which are named with a specific convention that you do
not know. For these reasons, the Tool provides near the tree frame a frame which helps to better
understand the nature and the scope of terms.

The frame we are talking about is located in the
right side of the main page.

As the snapshot shows, the Tool provides all the
data needed to define a term. In particular, the
‘Term naming and definition’ tab shows the
following information:

• State: the term type (raw commodity,
derivative etc.).

• Corex: a flag which indicates how detailed is
the food group defined by the term.

• Term Name

• Correlated Codes: some relevant codes for
the same food group in other classification,
e.g. the pesticide code.

• Scientific Names: the names used in official
taxonomies in relation to the selected term.

• Alias – Included terms: synonyms of the
term name or name of similar items which
are all included in the scope of the chosen
group.

• Scope notes: textual information helping
describing the selected term.

• Links: URL links which guide you to web
sites providing more specific information
related to the term.
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The Implicit facets tab, instead, shows you the
implicit facet descriptors for the selected term.
These descriptors are organised by facet and the
header of the facet is also given.

The tabs are updated each time you select a term in the tree panel.

An important feature of the scope notes is the
interactive search in the web.

To do this, select some interesting text which you
want to analyse better, and right click it. This will
open a contextual menu providing the option to
search the selected text in Google®, Google

Images® and Wikipedia®.

Moreover, you can directly translate a phrase

through Google Translate®.

Note that you can easily auto-select a single word
directly right-clicking it; the Tool will recognize the
clicked word and will open the contextual menu
on that word.

1.2.5. Describe feature: building a FoodEx2 code

The describe feature is the main function of the Tool, since it allows building the full complex FoodEx2
code of a given food.

In particular, this procedure implements all the rules described in the Chapter 5 of the report ‘The
food classification and description system FoodEx2 (revision 2)’ (EFSA, 2015).
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1.2.5.1. Description starting from the base term

Once you have decided which base term from the tree
panel needs to be described (by adding facet
descriptors), you can right click it and choose the menu
item Describe, in order to open the Describe Window.

Alternatively, you can simply double click the term of
interest.

The selected element will be treated as base term for
the describe function, and its code will automatically be
loaded into the Describe window.

The following snapshot shows the Describe Window:

On the left of the window all the facets for the described term are listed grouped by their type (the
implicit facets were automatically added by the Tool), while on the upper right the codes related to
the described term are shown. In particular, you can read the full code of the term, which is
generated by the base term code, concatenated with the explicit facets codes with the following
syntax:

BaseTermCode#FacetHeader1.FacetCode1$FacetHeader2.FacetCode2$...

In the picture, Andigena was chosen as base term and the Slicing process facet was added.
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Moreover, the Tool provides you also an interpreted version of the full
encoding. This is useful to understand which facets were added to the
base term with a human-readable text. In the example, the interpreted
code tells that a Slicing process facet was added to the base term
Andigena.

Note that if you set to TRUE the “copy implicit facets” preference (in the ‘user preferences’ entry of
the menu ‘Tools’), the full code and the interpreted code would include the implicit facets codes also.
The following pictures should clarify this concept.

The Describe Window also implements a system
which checks several business rules, in order to
guide you to a correct encoding. If you perform a
wrong encoding action, then the Log Console will
warn you with a text and the overall warning
level will be accordingly set (green= not an issue,
yellow= possible problem, red=probable serious
problem). For further details about the business
rules, see Section 1.2.5.4.

How can I add new facets to the description?

You can add new facets simply right clicking on the facet group
that you are interested in, and then clicking the “Add” menu item
in the contextual menu.

Alternatively, you can simply double click the facet group.

Once you have clicked the Add menu item, the following window will appear:
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You can use this window to select which
descriptors for the chosen facet to add to the
base term. If the selected facet group allows
adding more than one element, then the multiple
selection will be enabled, that is, the checkboxes
located on the left of the terms names will
appear. You can use this checkboxes to select
multiple descriptors at a time for the facet (if
allowed).

You can see that the interface of this window is very similar to the main page of the Tool; therefore
the usage is intuitive. In fact, a tree which allows browsing the facet descriptors and a search box to
search through them are provided (the global search options are used here as well as in the main
page search). Moreover, all the relevant data related to the descriptors are reported (i.e. scientific
names, alias and scope notes with links).

Note that an additional box called Selected Elements is
present. This box is used only in the multiple
selection case and it contains all the facets which
were selected until that moment and allows you to read
their information and possibly to remove them from the
selection. In fact, the facet descriptors will be actually
added only if you click the OK button.

The search panel works exactly in the same way as the
main one (Section 1.2.2). The only difference lies on
how the results are shown.

A simple search results window is opened when you
press the Go button or the ENTER key from the
keyboard. Here you can see all the search results and
then double click the descriptor which you want to add.

In the multiple selection case, the facet will be added
into the Selected Elements box. In the single selection
case, instead, the facet will be immediately added to
the base term, and the application will return to the
Describe Window.

At the end of this process you will return to the Describe Window, where you can add other facets or
copy the codes. In particular, once you have added all the required facets and thus generated the
final encoding, you can perform the following actions from the describe window:

• Copy the full code with the “Copy” button

• Copy only the interpreted code with the
“Copy description” button

• Copy both the full code and the interpreted
code (tab separated) with the “Copy
code+descr.” button

• Close the Describe Window with the “Close
window” button.

1.2.5.2. Description starting from a recently created code

We have seen that a term can be described starting from the base term, but actually this is not the
only way to describe a term. In fact, you can use more sophisticated functions provided by the Tool to
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make the description process easier and faster. In particular, you can start describing from a recently
created code or from a specific pick-list created ad-hoc for your encoding needs. In this Section we
focus on the former, while in Section 1.2.5.3 we show the latter.

For several reasons it usually happens that you need the code of a term which you have already
described recently. If you start from the base term, you will have to add all the required facets again,
in order to reproduce the old code. This could be a relatively long procedure.

The “Recently described terms” function is basically a way to recover the codes of terms which
you have described recently, in order to avoid the long procedure discussed above. Moreover, this
functionality allows also extending their code adding other facets, if you need to make more specific
encodings.

You can access the recently described terms by right clicking
anywhere in the main tree panel of the Tool. This will open
the usual contextual menu, which allows you selecting the
“Recently Described Terms” menu item.

A new window will be opened, from which you can access and
analyse the recently encoded terms.

The window shows a list of the terms which
were recently described with their full and
interpreted codes; you can scroll the list.

Additionally, you can search through the
terms using the search bar on the upper left.
This search function is particular, because it is
not subjected to the global search options. In
fact, for efficiency reasons it relies only on
term names and interpreted code.

Once you have selected a recent term, you
can either copy its codes or load the term into
the describe window using the “Load Term in
Describe” button. Describing a recent term
allows you adding new facet descriptors or
removing old ones.

For example, we can reload the “Andigena” term with the Slicing facet in the Describe Window to
modify it. It is clear that this procedure saves you a lot of time if you have to describe many similar
food items with slightly different characteristics.

Note that maintaining too many recent terms in memory could be useless and could hamper the
efficiency of the tool, since the term list could be subjected to some slowdowns. For this reason, the
default number of recently described terms which are stored is limited to ten. You can customize this
number accessing the User Preference window.

1.2.5.3. Description from a pick-list

Similarly to what explained in the previous Section (1.2.5.2), sometimes several terms could be
repeatedly encoded with the same or slightly different codes. In particular, each domain owns many
complex terms which are quite commonly used; therefore it is convenient to allow personalised coding
lists to help encoding common terms for a specific domain, and to standardize the encoding itself.

Here comes in the concept of “pick-list”, which is a CSV file semicolon-separated, that may contain
several complex terms which are common in a particular domain. These terms were already
described; therefore you can simply load them (in analogy to the recently described terms) into the
Tool to easily use the standard encoding or modifying it.
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How can I import and open a pick-list into the Foodex Browser?

Once you have created a pick-list (e.g. by saving as .CSV a spreadsheet with the appropriate structure
and content), it is sufficient to locate the file into the “Picklists” subfolder of the folder where the Tool
resides. The Foodex Browser will automatically recognize it.

Inside the Tool you can choose which
pick-list you want to use from the
Tools menu item.

Select Tools -> Favourite Pick List ->
….

In this way the Tool will use the
selected pick-list.

You can access the pick-list terms by
simply right clicking anywhere in the
tree main panel and selecting the
menu item “Favourite Picklist”.

This will open a new window very
similar to the one used for the
recently described terms.

The list of predefined terms is then
loaded into the Tool and you can
select the one you are interested in.
The search bar works exactly in the
same way as the one used in the
recent terms window (i.e. it uses the
term names to filter the results).

Here, you can either copy the term
codes or load them into the Describe
Window to modify their predefined
facets.

?

This functionality helps you saving time using standardized codes for your encodings. Moreover, it
allows avoiding encoding errors, since standardized codes are used.

If you are interested in creating your own pick-list, go at the end of this Section and read the “How
can I create my own pick-list” paragraph.

Advanced Search in the favourite pick-list

The Tool provides you even a smarter way to execute a search inside of a pick-list. In fact, you can
search which pick-list terms contain a specific term in their explicit/implicit facets. This allows you to
perform searches with a different criterion, which can be useful for some purposes.
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The procedure is really simple. Select from the
main tree panel the term which you want to
search in the pick-list, and right click it.

Choose from the usual contextual menu the
menu item “Search … in favourite picklist”.

The pick-lists window will appear, showing the search results in the pick-list term list.

The example shows the results of
a search, in which we have
chosen as search term the “Cattle
(live animals)”.

As you can see, the reported
pick-list terms shown are only the
terms which contain among their
explicit/implicit facets the term
“Cattle (live animals)”.

How can I create my own pick-list?

A pick-list is a CSV semi-colon separated file; therefore you can generate and easily edit it using a
spreadsheet. In this section, we explain how to create a correct pick-list by filling the right data into
the right column of the CSV file.

A pick-list contains three mandatory columns and an optional one. In particular, the mandatory fields
are:

• Level: this is an integer which can take any value greater or equal than 1. This column is
used for visualization purposes only. In fact, its value means “how much should this term be
indented in the pick-list?”. This feature is useful to distinguish groups of terms with a sort of
hierarchy. The default value is 1, which means no indentation.

• Pick-list elements: this is the name which will be visualized in the Pick-list Window to
identify the term. Note that this name is not only used for visualization purposes, since the
search inside the Pick-list window uses only this name as search field. Therefore, it could be
useful to insert in the name keywords or codes which discriminate the terms, in order to be
able to find what you need simply using the search bar function.

• Pick-list code: this is the foodEx2 encoding which contains the base term and all the explicit
facet descriptors following the FoodEx2 code standard pattern
(baseTermCode#FacetHeader1.FacetCode1$FacetHeader2.FacetCode2$...). Note that as
usual you should not include the implicit facet descriptors in this encoding, because they are
already present in the classification system. This field is used to load the base term and all the
added facet descriptors into the Describe Window.

The optional column is:

• allFacets: this is the full code of the base term related to the pick-list term. This encoding
follows the usual syntax of full codes (the same mentioned in the above point), but it contains
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only the codes of the implicit facet descriptors. This field was created for a more technical
reason. In fact, the implicit facet extraction from the database would take a long time, if the
pick-list is very long. This column provides this information directly without interacting with
the database, therefore the search function results less computational intensive. If the column
is not present, it is simply ignored by the program; if it is present, the search function
searches the selected term also in the implicit facets of the picklist terms. A picklist term with
an empty value in the ‘allFacets’ column will results as if it would have no implicit facets.

Once you have created your own pick-list, you can save it into the Picklists folder of the FoodEx
Browser as a CSV file (semi-colon separated) using the export function of Excel ‘save as CSV’. At
this point the picklist is ready to be chosen as favourite pick list and used by the browser.

If you require more information about the use of pick-list inside the Tool, see the beginning of this
Section.

1.2.5.4. Implementation of rules for coding while describing

At the beginning of the Section1.2.5, we said that the Describe Window implements a system which

checks if you are making a correct encoding and provides automatic warning during the coding

process. In this Section, we will provide additional information on this feature implementing the rules

described in the Chapter 5 of the report ‘The food classification and description system FoodEx2

(revision 2)’ (EFSA, 2015).

The Tool communicates with you through two graphical elements of the Describe Window. In

particular, the window includes a “semaphore”, which is a canvas highlighting through its colour the

eventual presence of potential errors and their severity (Overall warning level). Moreover, a log

console (Message Log) sends messages explaining the possible issues encountered during the

encoding until now.

Note that also the messages are coloured
based on the severity colour scale, but are
not necessarily linked to the semaphore
colour. In fact, some messages can be
somewhat serious, but if the Tool cannot
conclude that there is a real mistake, the
semaphore will not be changed. These
peculiar messages usually suggest you to
check some facets, because they may be
one of the allowed exceptions or a serious
error.

Green messages and semaphores tell you
that no known potential mistake was
identified.

Yellow and red colours tell you instead that
a low level and a high level warning were
raised respectively. In both cases, check
accurately the possible errors following the
messages of the log console.
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